Service Incident on the Soracom Platform - Soracom Air for Cellular (planX3, planX3-EU)

Minor incident Air for Cellular planX3 (Rendezvous point: Frankfurt)
2026-06-24 11:44 JST · 2 hours, 17 minutes

Updates

Post-mortem

Summary

Between 2026-06-24 02:00 and 2026-06-24 03:55 UTC, some Soracom Air SIM subscriptions experienced issues where new cellular communication sessions could not be established.

Affected Services

During this period, devices using the following subscriptions were affected:

planX3
planX3-EU

Data communication via already established cellular communication sessions was not affected.

Cause

In preparation for migrating to a new system, Soracom had been running a new system responsible for cellular session establishment alongside the original system, gradually increasing the number of sessions being hosted on the new system. When the parallel operation evaluation phase concluded, all processing was migrated to the new system prior to this incident. Following the migration, normal operations were confirmed to be functioning without issue.

However, at approximately 02:00 UTC on the same day, requests for new session connections concentrated within a short period. Cellular session establishment requests can sometimes spike rapidly due to device usage patterns or automated device reconnection behavior. A post-incident investigation revealed a defect in the new system that prolonged processing times when connection requests spiked. During the affected period, the time required to process session establishment was longer than it would have been under the original system.

Devices using these subscriptions connect to Soracom via network partner infrastructure through local Mobile Network Operator (MNO) networks. The network partner’s infrastructure enforces a timeout threshold for session establishment requests. Because the response time from Soracom’s system exceeded this timeout threshold, session establishment processing could not be completed, preventing some devices from initiating cellular communication.

Resolution

At 02:19 UTC, Soracom recognized this event as an incident and initiated its incident response framework. Upon identifying the abnormal communication status, Soracom promptly updated the Status Dashboard to notify customers, and simultaneously began an internal investigation while escalating the issue to the network partner.

Based on our investigation and responses from the network partner, the aforementioned cause was identified. At 03:44 UTC, Soracom executed a rollback of a portion of its system resources back to the original configuration. After confirming a trend toward recovery, a rollback of all remaining resources was performed, and full recovery was confirmed at 03:55 UTC.

Future Actions

We are addressing the aforementioned defect in the new system and will roll it out in phases following performance validation.

Additionally, to reduce the time required for the initial detection and identification of such incidents, we will improve our system monitoring configurations and alert settings to accurately measure and monitor response times for session establishment requests. Furthermore, we will consider adding new metrics to better evaluate the overall health of Soracom in order to improve service quality and shorten the time required from anomaly detection to recovery.

2026-07-01 · 13:01 JST
Resolved

The service incident on the Soracom platform has been fully resolved:

[Affected Services]
Soracom Air for Cellular IoT SIM cards on plans:

  • planX3
  • planX3-EU

[Issues Identified]
SIMs from all subscriptions could not connect to the network or experienced difficulty connecting.

[Incident Timeline]
Times are in UTC:

  • Start of Incident: 2026-06-24 02:00
  • Start of Recovery Trend: 2026-06-24 03:44
  • Fully Resolved: 2026-06-24 05:00

[Current Status]
Following the countermeasures implemented by our engineering team, a recovery trend was observed from 03:44 UTC, and we have confirmed full recovery as of 05:00 UTC.

We sincerely apologize for any inconvenience caused. If you have any further questions, please contact our support team:
https://developers.soracom.io/en/docs/account/support/

2026-06-24 · 13:59 JST
Monitoring

We are currently experiencing a service incident on the Soracom platform:

[Affected Services]
Soracom Air for Cellular IoT SIM cards on plans:

  • planX3
  • planX3-EU

[Issues Identified]
SIMs from all subscriptions cannot connect to the network or are experiencing difficulty connecting.

[Incident Timeline]
Times are in UTC:

  • Start of Incident: 2026-06-24 02:00
  • Start of Recovery Trend: 2026-06-24 03:44

[Current Status]
Our engineering team has observed a recovery trend and is monitoring the service as it recovers.

[Next Update]
As soon as the situation changes or at 2026-06-24 05:00 UTC

We apologize for any inconvenience this may cause. If you need assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/

Thank you for your understanding and cooperation.

2026-06-24 · 13:00 JST
Issue

We are currently experiencing a service incident on the Soracom platform:

[Affected Services]
Soracom Air for Cellular IoT SIM cards on plans:

  • planX3
  • planX3-EU

[Issues Identified]
Some SIMs from the affected plans cannot connect to the network on the following carriers:

  • TBA

[Incident Timeline]
Times are in UTC:

  • Start of Incident: 2026-06-24 02:00

[Current Status]
Our engineering team is actively investigating the issue.

[Next Update]
As soon as the situation changes or at 2026-06-24 04:00 UTC

We apologize for any inconvenience this may cause. If you need assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/

Thank you for your understanding and cooperation.

2026-06-24 · 11:40 JST

← Back