Service Incident on the Soracom Platform - Soracom Air for Cellular (plan-D)
Updates
Incident Summary
Between 2026-04-03 10:22 and 15:29 UTC, devices using Japan Coverage IoT SIMs on plan-D were unable to use data communication services.
Incident Timeline
Devices using the affected subscriptions connect to Soracom via NTT docomo’s infrastructure.
Around 2026-04-03 10:10 UTC, a rapid increase was observed in session creation requests with specific unsupported conditions sent from these subscriptions to the component responsible for processing cellular communication sessions (hereafter referred to as the P-GW). The P-GW responds to such requests with rejection messages via the carrier network to IoT devices.
As the volume of these requests significantly exceeded normal levels, the P-GW entered an unstable state. As a result, from around 10:22 UTC, the P-GW became unable to properly process cellular connection requests and data packets.
The P-GW is configured with redundancy, auto scale-out capabilities, and automatic process recovery mechanisms. However, due to the conditions described above, sufficient performance to sustain normal processing could not be maintained, ultimately resulting in data communication becoming unavailable for the affected subscriptions.
An alert triggered by a sharp decrease in data traffic initiated an investigation by our engineering team at 10:33 UTC, and an incident response structure was established. In parallel, customer notifications were issued via the Status Dashboard, and coordination with NTT docomo was initiated.
Based on the investigation results, a workaround was applied to a subset of P-GW instances at 12:18 UTC, and improvements in connectivity and data communication were confirmed. The workaround was then deployed across all P-GW instances, and recovery of connectivity was confirmed from approximately 12:54 UTC. Additional measures continued to be applied, and the incident was declared resolved at 15:29 UTC.
This incident did not affect Japan Coverage IoT SIMs other than plan-D, nor Global Coverage IoT SIMs.
Root Cause
Session creation requests with specific unsupported conditions directed to the P-GW had been observed under normal conditions prior to this incident. However, no performance issues had been identified under the request volumes observed before the incident occurred.
The investigation confirmed that the volume of such requests increased significantly around the time of the incident. Furthermore, the applied workaround, which included improvements to the handling of these requests, was effective.
Based on these findings, we concluded that the incident was caused by an abnormal request pattern exposing a latent issue within a P-GW component related to the processing of these requests, which led to degraded performance.
Future Actions
The latent performance issue related to handling session establishment requests containing specific unsupported conditions has been mitigated through the applied workaround, and we have identified the component that caused the issue.
We will continue to assess other subscription-related infrastructure and apply similar workarounds where necessary.
We remain committed to continuous infrastructure improvements. To minimize the duration of impact on customer systems and devices, we will further enhance monitoring and alerting, and continue efforts to reduce response times and improve overall service quality.
The following service incident occurred on the Soracom platform:
[Affected Service]
Soracom Air for Cellular IoT SIM cards on plan:
- plan-D
[Issue Identified]
All SIMs on the affected plan were unable to use data communication
[Incident Timeline]
Times are in UTC:
- Start of Incident: 2026-04-03 10:20
- Start of Recovery Trend: 2026-04-03 12:20
- End of Incident: 2026-04-03 15:29
We will confirm the situation and provide further details on this page during the week of April 6, 2026.
We apologize for any inconvenience this incident may have caused.If you still require assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/
Thank you for your understanding and cooperation.
We are currently experiencing a service incident on the Soracom platform:
[Affected Service]
Soracom Air for Cellular IoT SIM cards on plan:
- plan-D
[Issue Identified]
All SIMs on the affected plan are unable to use data communication
[Incident Timeline]
Times are in UTC:
- Start of Incident: 2026-04-03 10:20
- Start of Recovery Trend: 2026-04-03 12:20
[Current Status]
Our engineering team is addressing impacts affecting some use cases and continues to monitor the service.
[Next Update]
As soon as the situation changes or at 2026-04-03 17:00 UTC
We apologize for any inconvenience this may cause. If you need assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/
Thank you for your understanding and cooperation.
We are currently experiencing a service incident on the Soracom platform:
[Affected Service]
Soracom Air for Cellular IoT SIM cards on plan:
- plan-D
[Issue Identified]
All SIMs on the affected plan are unable to use data communication
[Incident Timeline]
Times are in UTC:
- Start of Incident: 2026-04-03 10:20
- Start of Recovery Trend: 2026-04-03 12:20
[Current Status]
Our engineering team is addressing impacts affecting some use cases and continues to monitor the service.
[Next Update]
As soon as the situation changes or at 2026-04-03 16:00 UTC
We apologize for any inconvenience this may cause. If you need assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/
Thank you for your understanding and cooperation.
We are currently experiencing a service incident on the Soracom platform:
[Affected Service]
Soracom Air for Cellular IoT SIM cards on plan:
- plan-D
[Issue Identified]
All SIMs on the affected plan are unable to use data communication
[Incident Timeline]
Times are in UTC:
- Start of Incident: 2026-04-03 10:20
- Start of Recovery Trend: 2026-04-03 12:20
[Current Status]
Our engineering team is observing a recovery trend and are monitoring the service as it is recovering.
[Next Update]
As soon as the situation changes or at 2026-04-03 15:00 UTC
We apologize for any inconvenience this may cause. If you need assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/
Thank you for your understanding and cooperation.
We are currently experiencing a service incident on the Soracom platform:
[Affected Service]
Soracom Air for Cellular IoT SIM cards on plan:
- plan-D
[Issue Identified]
All SIMs on the affected plan are unable to use data communication
[Incident Timeline]
Times are in UTC:
- Start of Incident: 2026-04-03 10:20
- Start of Recovery Trend: 2026-04-03 12:20
[Current Status]
Our engineering team has observed a partial recovery trend and continues to work on resolving the issue.
[Next Update]
As soon as the situation changes or at 2026-04-03 14:00 UTC
We apologize for any inconvenience this may cause. If you need assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/
Thank you for your understanding and cooperation.
We are currently experiencing a service incident on the Soracom platform:
[Affected Service]
Soracom Air for Cellular IoT SIM cards on plan:
- plan-D
[Issue Identified]
All SIMs on the affected plan are unable to use data communication
[Incident Timeline]
Times are in UTC:
- Start of Incident: 2026-04-03 10:20 UTC
[Current Status]
Our engineering team is working in coordination with NTT Docomo to resolve the issue.
[Next Update]
As soon as the situation changes or at 2026-04-03 13:30 UTC
We apologize for any inconvenience this may cause. If you need assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/
Thank you for your understanding and cooperation.
We are currently experiencing a service incident on the Soracom platform:
[Affected Service]
Soracom Air for Cellular IoT SIM cards on plan:
- plan-D
[Issue Identified]
Some SIMs on the affected plan are unable to use data communication.
[Incident Timeline]
Times are in UTC:
- Start of Incident: 2026-04-03 10:20 UTC
[Current Status]
Our engineering team is actively investigating the issue.
[Next Update]
As soon as the situation changes or at 2026-04-03 12:30 UTC
We apologize for any inconvenience this may cause. If you need assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/
Thank you for your understanding and cooperation.
We are currently experiencing a service incident on the Soracom platform:
[Affected Service]
Soracom Air for Cellular IoT SIM cards on plan:
- plan-D
[Issue Identified]
Some SIMs on the affected plan are unable to use data communication.
[Incident Timeline]
Times are in UTC:
- Start of Incident: TBD
[Current Status]
Our engineering team is actively investigating the issue.
[Next Update]
As soon as the situation changes or at 2026-04-03 11:30 UTC
We apologize for any inconvenience this may cause. If you need assistance, please contact our support team:
https://developers.soracom.io/en/docs/account/support/
Thank you for your understanding and cooperation.
← Back